Configuration.module tiene un error de 'cargadores' de propiedad desconocida al configurar el módulo webpack

Configuration Module Has An Unknown Propertyloaderserror When Configuring Webpack Module

Estoy usando gulp en mi proyecto.

Al ejecutar gulp, informé el siguiente error:



WebpackOptionsValidationError: Objeto de configuración no válido. Webpack se ha inicializado mediante un objeto de configuración que no coincide con el esquema de API.
- configuration.module tiene una propiedad desconocida 'loaders'.



La razon es la siguiente:



El parámetro del módulo que configuré aquí es loaders y la API se modificó después de webpack2.0. Reemplace los cargadores con reglas.



Ejecutar después de la modificación, sin error, el problema está resuelto.

Cambio de registro: 29 de marzo de 2019 17:16:06 Reemplace el babel con el babel-loader en el cargador dentro de las reglas