Error: error de sintaxis, las declaraciones 'para cada' solo están disponibles si el nivel de origen es 5.0

Error Syntax Error

Escriba un programa hoy para administrar sus propios archivos, el fragmento del programa es el siguiente:

|_+_|

Sin embargo, cuando escribí para (:), cometí un error. Me quedé perplejo. Este foreach se ha utilizado muchas veces. No he tenido ningún problema antes, pero esta vez jugué, aunque sigo creyendo que no escribí. Incorrecto, y luego verifiqué alguna información para confirmar que la gramática es correcta. Oh, recibe un mensaje, este uso solo está disponible después de JDK5.0. Echa un vistazo a ECLIPSE, usando jdk1.6, esto no es un problema. Esto me deprime mucho. Desesperado, use javac para ejecutar (computadora instalada jdk1.6), no hay problema, ¡déjelo!



Hay una idea, definitivamente es un problema con este ECLIPSE. La conjetura es que este software de edición o problema de compilación, y más tarde encontró el compilador. Modifíquelo, está bien, la cruz roja que estaba mal se ha ido. Operaciones específicas:



Buscar ventana -> preferencias -> java -> compilador



Mire el lado derecho para modificar el nivel de cumplimiento completo, modifique el nivel para superar 5.0.