Sap

Cómo manejar los mensajes de error de Eclipse El paquete declarado no coincide con el paquete esperado

How Handle Eclipse Error Messages Declared Package Does Not Match Expected Package

Después de descargar un proyecto de código abierto de github, encontré este molesto mensaje de error después de importar en mi propio Eclipse:
El paquete declarado 'com.sap.smartService' no coincide con el paquete esperado 'main.java.com.sap.smartService'

Este es mi directorio de archivos de proyecto:



Solución: haga clic derecho en el proyecto y seleccione Propiedades-> Ruta de construcción. La carpeta src está configurada para construir la ruta.



Primero haga clic con el botón derecho en la carpeta src y seleccione Eliminar de la ruta de compilación para eliminarla de la ruta de compilación:



Luego seleccione la carpeta java en src / main, configúrela para construir la ruta y reinicie Eclipse:

El error desaparece:

Para obtener más del artículo original de Jerry, preste atención al número público 'Wang Zixi':