Las expresiones lambda no se admiten en -source 1.7 (use -source 8 o superior para habilitar las expresiones lambda)

Lambda Expressions Are Not Supported Source 1

El sdk de 1.idea, jdk también se ha configurado en java1.8
imagen
imagen
2. El entorno local de JVM también es 1.8
imagen
sigue siendo así
imagen
Descubrí que el entorno java para mi configuración de maven no es 1.8. Seleccione el archivo de configuración de maven utilizado por idea
imagen
Se modifica la ubicación del archivo pom del proyecto:

imagen

Se reproduce la referencia: https://blog.csdn.net/qwdafedv/article/details/54691740