La compilación del módulo falló (desde ./node_modules/babel-loader/lib/index.js) se informa cuando webpack usa babel-loader para empaquetar:

Module Build Failed From

Después de una comida, Baidu concluyó que la versión de babel estaba en conflicto.

Estoy usando webpack 4.x, desinstale directamente el babel instalado previamente





Luego instale la última babel



Puede ver las nuevas dependencias en package.json



Cree un nuevo archivo .babelrc en el directorio raíz

Escribe así en webpack.config.js

Después de ejecutar npm build, abra el archivo js empaquetado y busque la sintaxis ES6 const para ver si es así.