el módulo 'seaborn' no tiene una solución de atributo 'diagrama de dispersión'

Module Seaborn Has No Attribute Scatterplot Solution

En primer lugar, seaborn incluye el módulo de diagrama de dispersión. Pero ejecutar la oración correspondiente sin error de sintaxis informará un error porque la versión actual de seaborn es 0.8 o inferior.

Los ejemplos de errores son los siguientes:





Solución: ¡Actualice la versión seaborn! La oración correspondiente es: pip install seaborn == número de versión correspondiente, como: pip install seaborn == 0.9.0



Vuelva a ejecutar la declaración, puede hacer un dibujo normal:



Durante este período, cmd puede solicitar una actualización y ejecutarla varias veces: python -m pip install --upgrade pip puede no ser válido

Will Error, comentarios sobre problemas de permisos similares, métodos de depuración específicos pueden hacer referencia a lo siguiente:

https://blog.csdn.net/weixin_43870646/article/details/90020874

Si aparece: ningún módulo llamado pip.basecommand

Se recomienda desinstalar la versión anterior y reinstalar la nueva, los pasos correspondientes. O puede consultar el método del autor para probar: https://blog.csdn.net/GuaPiQ/article/details/100593848

Después de reinstalar pip, puede actualizar seaborn de acuerdo con el primer paso anterior.