el módulo 'importlib._bootstrap' no tiene atributo 'SourceFileLoader'

Moduleimportlib _bootstraphas No Attributesourcefileloader

Hubo un error al ejecutar un script de otra persona hoy: el módulo 'importlib._bootstrap' no tiene atributo 'SourceFileLoader' apareció al importar keras y gradualmente encontró pistas.

Originalmente había una instalación de biblioteca de dependencias antes de ejecutar, una de las cuales era socketio, apareció una advertencia durante la instalación de pip, ipython 6.5.0 tiene requisitos de configuración de herramientas> = 18.5, pero tendrá setuptools 3.3 que es incompatible. El problema está en setuotools. Ejecutar en cmd:



|_+_|

Puede obtenerlo después de actualizar.



Al final, los problemas con los que todos se encuentran serán diferentes. Identifique cuidadosamente los puntos problemáticos y divídalos uno por uno para hacerlo. ¡Vamos, año de Sao!