Varios marcadores en esta línea @Override

Multiple Markers This Line Override

Utilice Eclipse para el desarrollo de proyectos. Si agrega @Override delante de los métodos en la clase de implementación, se le preguntará.Varios marcadores en esta línea'El error se describe de la siguiente manera

Varios marcadores en esta línea
- El método getStudentByID (String) de tipo StudentBeanImpl debe anular un método de superclase
- implementa mgr.jc.student.service.IStudentBean.getStudentByID





La razón del problema anterior. JDK 1.5 no admite este tipo de escritura. La implementación de métodos de interfaz requiere anular los métodos abstractos.



La solución al problema anterior es la siguiente:

Método 1. SeleccioneVentana de Eclipse → Preferencias → Java → Compilador cambia el nivel de cumplimiento del compilador de 1.5 a 1.6.



Método 2. Haga clic derecho en el proyecto y seleccione las últimas propiedades para seleccionar el compilador de Java a la izquierda. Marque la casilla dentro y cambie la versión del editor de Java a 1.6.

Método 3. Haga clic con el botón derecho en la biblioteca del sistema JRE en el proyecto [JavaSE-1.5] → Propiedades, entorno de ejecución Seleccione “JavaSE-1.6 (JDK1.6.0_10)” y haga clic en Aceptar.

Los tres métodos anteriores pueden resolver los problemas mencionados en el título, y pueden elegir la solución correspondiente de acuerdo con sus propios hábitos.