[ERROR] No se proporciona ningún compilador en este entorno. Quizás esté ejecutando un JRE en lugar de un

No Compiler Is Provided This Environment

tres métodos:
El primero que modifiqué jre parecía inútil
Se dice que el segundo es el mejor método. Sin embargo, todavía no me he puesto en contacto con Spring, así que me rendiré
El tercer experimento personal es ciertamente factible, pero no se puede hacer de una vez por todas. A
También espero que un maestro pueda venir al laberinto. .


Hoy es un día realmente malo para mí. Pasé mucho tiempo descargando la última versión comprimida de Spring Tool Suite basada en Eclipse 4.4.1, pero ahora aparece el siguiente error.



|_+_|
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16

¿Alguien conoce el problema? Gracias por adelantado.



Pregunta de Navdeep en 2014-12-16 09: 36: 03.0




Puede elegir cualquiera de las siguientes formas de resolver [ERROR] No se proporciona ningún compilador en este entorno. ¿Quizás está ejecutando un JRE en lugar de un JDK?

Método 1

  • Haga clic en Windows -> Preferencias -> Java -> JRE instalados -> Agregar -> VM estándar, luego seleccione JAVA_HOME
    JAVA_HOME
  • Seleccione el nuevo JRE del JRE instalado y haga clic en Aceptar
    JRE

Método 2

El más simple y aplicable en todos los escenarios

  • El primer paso es abrir el directorio de instalación de Spring Tool Suite (STS)
  • Paso 2: haga clic con el botón derecho en STS.ini
  • En el tercer paso, abra -VM JAVA_HOME / bin / javaw.exe y reinicie Eclipse Spring Tool Suite (STS), Eclipse obtendrá automáticamente este JDK
|_+_|
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18

Método 3

Abra pom.xml, ingrese la parte resaltada e ingrese la ruta JDK correcta. (No se admite el resaltado parcial, de principio a fin)



|_+_|