En cuanto a la selección no se puede ejecutar en ningún error del servidor, cómo solucionarlo rápidamente.

Regarding Selection Cannot Be Run Any Server Error

Recientemente, al importar un proyecto externo, encontré un problema, es decir, apareció el error en la figura.
la selección no se puede ejecutar en ningún servidor (no se puede ejecutar la selección en ningún servidor)
imagen
El motivo de este error es que la versión del Dynamic Web Module no coincide con la del servidor. Se puede acceder a la versión de Dynamic Web Module haciendo clic con el botón derecho en el nombre del proyecto -> propiedades -> Facetas del proyecto

Puede ver que cuando el número de versión es 4.0, el número de versión no coincide con el servidor y el servidor de la derecha no es opcional.
¿Cómo cambio el número de versión?
Busque esta carpeta de proyecto en el espacio de trabajo de eclipse ->. Settings-> org.eclipse.wst.common.project.facet.core.xml
(Ejemplo: la ruta del espacio de trabajo para eclipse en mi computadora es: D: eclipseCode day_45_bookstore.settings)
Abra y cambie el número de versión 4.0 de jst.web a 3.0 o inferior. Reinicie Eclipse.
Tenga en cuenta que también puede modificar la versión de Tomcatd. Versión Jdk y así sucesivamente.
asi que imagen
Si el número de versión no se ha corregido y el problema no se puede resolver, solo se puede modificar.
Mira las dos imágenes a continuación. Después de hacer clic en Tiempos de ejecución en la tercera imagen, seleccione Nuevo y vaya a la página de la cuarta imagen. Después de seleccionar una de las versiones de Tomcat, haga clic en Aplicar. Entonces el error de ejecución desaparecerá.
Inserte una descripción de la imagen aquí
*

El problema final se resolvió satisfactoriamente